Welcome guest, is this your first visit? Click the "Create Account" button now to join.
Results 1 to 5 of 5
  1. #1
    Junior Member
    Join Date
    Jan 2013
    Location
    US
    Posts
    2
    Rep Power
    0

    Default Garmin Nuvi 1200 Stuck on Loading Screen w/ Green Progress Bar at 1/4 [SOLVED]

    Hi all, and thanks for looking at my post! I tried to do an advanced search before posting but couldn't seem to find a legit topic on my issue at hand.

    I have a Garmin Nuvi 1200 and it's never had a software update. Recently it became stuck at "Loading Maps." I connected it to a desk top and this seemed to fix the issue. Again, never updating the software.

    Now the unit will not get stuck on "Loading Maps," but instead will get to a screen with a picture of a mountain valley with two houses on the hillside, and a green progress indicator at approximately 1/4.

    I called customer service and they want me to send in the unit for repair at 99 dollars. I'd rather just spend a few more bucks and get an upgrade instead. With this in mind, I began to fiddle around a bit and opened up the unit. I was able to disconnect the battery in hopes of it completing a "hard reset." This did not work. Speaking of hard reset, I can perform this function-- to a certain extent. I can get the hard reset screen to invoke, but it will not let me make a selection of yes or no.

    Any ideas on what I could do to "fix" my issue besides:

    A. Send the unit in for repair
    B. Buy a new unit

    Thanks in advance for looking/helping, and sorry if this was covered in another thread. I looked but could not find.

    Cheers!

    Grant

  2.    Advertissements


  3. #2
    ☼ADMIN☼
    catymag's Avatar
    Join Date
    Nov 2007
    Location
    light side
    Posts
    23,587
    Rep Power
    5315

    Default

    Have you tried an hard reset? Have you tried to flash it with Webupdater?
    If nothing works you need a cure for your Nuvi, you can find it in this thread
    [Only registered and activated users can see links. ]

    [Only registered and activated users can see links. ]
    Webupdater
    Code:
    Please Login or Register to see the links
    [Only registered and activated users can see links. ]
    [Only registered and activated users can see links. ]

    [Only registered and activated users can see links. ]
    You have to navigate to get to the good.
    Nuvi1250/Nuvi 34xx/Nuvi 2200/Nuvi 66/Oregon 600/Galaxy S5 MM 6.0.1/TomTom GO/iGO Nextgen Avic,Basar,Isr.Gift/Navigon
    Please don't flood my pm box with questions you can post on forum!! You won't hear back from me.

  4. #3
    Junior Member
    Join Date
    Jan 2013
    Location
    US
    Posts
    2
    Rep Power
    0

    Default

    Catymag,

    TYVM for the information and quick reply! I was able to follow the instructions to a TEE, and get my unit working again. I just knew there was a way to get it back to normal ops without having to ship it to Garmin and fork over a hundred bucks.

    Kudos to this site and all the moderators and contributors out there! Thank you everyone!

    ~Grant

  5. #4
    Junior Member
    Join Date
    Jan 2013
    Location
    US
    Posts
    2
    Rep Power
    0

    Default

    Just a quick breakdown of issue and resolution:

    Could not flash with Webupdater because desktop would not recognize unit.

    Could not hard restart unit as the utility would invoke but would not allow a yes or no response when pressed.

    Had to use GarminCure3 Tool by Kunix and load firmware as an original and not a cure. <----This is what fixed my devise!

    Note to others: Make sure you know how to get your devise into Pre Boot Mode prior to attempting.

  6. #5
    Navigation software expert

    Giomen's Avatar
    Join Date
    Apr 2009
    Location
    Suomi-Russia
    Age
    49
    Posts
    2,578
    Rep Power
    589

    Default

    If you will have repeated this problem thereby you have something wrong in Nuvi 1xxx.

    I had similar situation several times. I must to find troubleshooting by exclusion by renaming and deleting files. It was voice, GPI, EULA and GPX files. Sometime the very big mlg_history.db file was reason for super long loading after a few hundreds of thousand km on odometer.
    To enter the masstorage mode I do about next:

    1. With the nuvi powered off, press and hold the upper left hand corner of the touchscreen with your finger
    2. Continue to hold the touchscreen while pressing and releasing the power button on the device. The Garmin Logo should display
    3. Continue to hold the touchscreen while connecting the device to your computer
    4. After 30 seconds, the screen should flash white. At this point, release the touchscreen. A green progress bar should display on the device. After the progress bar completes (45-60 seconds), the device should go into Mass Storage mode
    5. Open the nuvi drive that appears in My Computer or Computer

    Original source is from:
    https://support.garmin.com/support/searchSupport/case.faces?caseId=%7B01474db0-8dc8-11df-f376-000000000000%7D
    But I usually released the touchscreen after a green progress bar display on the device and often I was waited a few minutes before progress bar display or complete. My friend tell me what he put a finger on center of touchscreen and this work too.
    Love your wife? Buy yourself a GPS for answering to her favorite question: "Dear, where are you?".

 

 

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
This website uses cookies
We use cookies to store session information to facilitate remembering your login information, to allow you to save website preferences, to personalise content and ads, to provide social media features and to analyse our traffic. We also share information about your use of our site with our social media, advertising and analytics partners.