Welcome guest, is this your first visit? Click the "Create Account" button now to join.
Page 1 of 4 123 ... LastLast
Results 1 to 10 of 31
  1. #1
    IGo Moderator Black Wolf's Avatar
    Join Date
    Jan 2010
    Location
    Near
    Posts
    312
    Likes (Given)
    172
    Likes (Received)
    4561
    Dislikes (Given)
    0
    Dislikes (Received)
    1
    Rep Power
    148

    ? Garmin nuvi 765 "system software missing"

    Hello everbody,

    i hope somebody will can help me, or share similary expirience like my, with nuvi 765... I didn't find some specific thread about 765 nuvi with this problem, else this about 1xxx series

    [Only registered and activated users can see links. ]

    so i opened new thread...

    Problem is next, this nuvi 765 had some problems with corrupted internal memory, it was fat32 FS, but however, was corrupted internal memory, symptoms were, that deleting some files weren't possible, if i deleted files, and then again power on it, files were again there, or some strange files inside some folders, like corrupted files, which can't be deleted manually... So i was afraid to format directly internal memory, and decided to flash it with latest firmware 4.50, cause rest of links here in section for 765 firmware were dead here

    [Only registered and activated users can see links. ] , but caty will reupload them soon ...

    I'm not sure is danger to flash from lower version like 2.20 directly 4.50, i forgot did i read somewhere that is better to update it build by build...

    So i decided to risk , PC couldn't see this 765 item, OS saw 765 internal memory like hidden removable device, and sometimes was hidden, sometimes not, it made some cycles of 1-2 seconds hidden and unhidden removable device, so i couldn't flash it through usb cable, or i didn't know in that moment tip "power off, press in middle of screen, and by holding on middle of screen, turn lock on power off button, and then until hold finger on middle of display, to connect it to PC" , called action - usb mode activating, i discovered this so late ... And in meantime, i decided to flash it by SD CARD, downloaded 4.50 firmware, renamed to GUPDATE.gcd, power off device, inserted SD CARD (formatted FAT-2GB SD card), and then turn on 765 item, flashing - updating firmware started by message "SOFTWARE LOADING" wait, i flashed some my previous Garmin items, and remember that flashing firmare doesn't take more than 10-20 minutes, so i waited 30 and more minutes, but message "software is loading" was still there, no reset by itself 765 pna.

    So i decided to risk again, and turned off device manually, cause though that flashing stucked on software loading, and wanted to start up once more flashing, but then bad news , message "SYSTEM SOFTWARE MISSING", and new problems...

    After this, flashing by SD CARD wouldn't work anymore ... I tried 4.40 version, but no, again same message ... So i discovered way for making usb connection by some tips on gpspassion, and using GarminCure3 from kunis, i tried to reflash this item, but then appeared this message, i don't know why, and how to bypass this message and to flash device, why message for wrong region ?

    [Only registered and activated users can see links. ]

    I tried voyager procedure, from this post

    [Only registered and activated users can see links. ]

    but again same, even there wasn't ntfs formatted internal memory, i tried like some last try of something ...

    So please, if somebody has some suggestion, advice, what to try, post it here ? How to bypass this message "system software is missing", it seems isn't totally dead, cause kunis's tool GarminCure3 see this item through usb connection and ID of this item, and try to flash it, but then fails, like on picture, so what wrong i do with this tool ? Or maybe i'm wrong, and this item is lost ?

    Or maybe to try lower version of firmware like 2.50, which is immediately after 2.20 ?

    Tnx!

    Greetzz!

  2. #2
    ☼ADMIN☼
    catymag's Avatar
    Join Date
    Nov 2007
    Location
    Light Side
    Posts
    13,867
    Likes (Given)
    12960
    Likes (Received)
    95260
    Dislikes (Given)
    39
    Dislikes (Received)
    3
    Rep Power
    1798

    Default

    vers.2.50 is reuploaded and posted in summary, here
    nuvi7x5_regionfileonly__300.gcd
    [Only registered and activated users can see links. ]
    and
    nuvi7x5_regionfileonly__360.gcd
    [Only registered and activated users can see links. ]

    [Only registered and activated users can see links. ]

    Galaxy SII Jelly Bean 4.1.2 / Nuvi1200->1250 / Nuvi3790T->34xx / Nuvi 2200 / GPSMAP 62st / Oregon 600

  3. #3
    IGo Moderator Black Wolf's Avatar
    Join Date
    Jan 2010
    Location
    Near
    Posts
    312
    Likes (Given)
    172
    Likes (Received)
    4561
    Dislikes (Given)
    0
    Dislikes (Received)
    1
    Rep Power
    148

    Default

    Thank you very much caty for fast reponse! Update for new state of this nightmare's 765 , finally i suceed flash it with 2.50 firmware, firstly with option "cured" from kunix's tool Garmin Cure, it finished updating with this tool, no more message "system software missing", at the end of flashin on Garmin cure wass message "update was sucessfull" but now new message on screen "loader loading", and it stays there longer !? What to do next, to disconnect item from usb port, or to flash it with original 2.50 ? I though after flashin with cure firmware, made by kunix's tool, it will reboot at all, and will be accesible by Win explorer, that i can format it, by tool suggested here,

    [Only registered and activated users can see links. ]

    and then to flash it by 2.50 - original, but now i can't , cause OS doesn't see 765 still !?

    If someone has some new suggestion, please post it ...

    New picture with message, that flashin past ok ...

    [Only registered and activated users can see links. ]
    Tnx!
    Last edited by Black Wolf; 27-09-2012 at 02:25 AM.

  4. #4
    Navigation software Moderator

    kunix's Avatar
    Join Date
    Sep 2011
    Location
    Belarus
    Posts
    658
    Likes (Given)
    85
    Likes (Received)
    965
    Dislikes (Given)
    1
    Dislikes (Received)
    0
    Rep Power
    141

    Default

    I'm glad you're still able to flash new firmwares, because that "unable to program the requested memory region" message occuring when flashing a normal RGN (not a manually crafted one with weird region numbers) means that the flash chip is broken.
    Some devices just don't automatically reboot after flashing firmware, GarminCure3 has nothing to do with that. So disconnect the device from the PC, turn it off, and connect it back.
    Also if your device is able to boot with the corrupted internal filesystem, then you don't need patching firmwares with GarminCure3. Just format it with HMPRERPUSB.

  5. #5
    IGo Moderator Black Wolf's Avatar
    Join Date
    Jan 2010
    Location
    Near
    Posts
    312
    Likes (Given)
    172
    Likes (Received)
    4561
    Dislikes (Given)
    0
    Dislikes (Received)
    1
    Rep Power
    148

    Default

    Hello Dear kunix,

    thank you very much for fast reponse! I flashed it with 2.50 firmware, but after flashing is finished with GarminCure3, i pressed ok, GarminCure3 windows close, and i waited on 765 to reboot, like normally would happens , but no, it stays whole time 10-15 minutes with screen message "Loader loading", i saw that you made some modification on firmware of Kenwood, for similary problem like my in this thread [Only registered and activated users can see links. ]

    So can you maybe edit this 2.50 firmware

    [Only registered and activated users can see links. ]


    similary you did for kenwood, to prepare some .rgn, which will bypass this message after flashing cure firmware?


    I made manually cure .rgn, then by renaming all necessary files with hex editor, .img to .xmg, .gcd to .xcd, etc. like caty explained in thread for manually creating cure .rgn, but same results, at all it flashed 765, but "loader loading" still is on screen , no reboot of item, that i can see 765 in mass storage, and to be able format it by HMPRERPUSB tool ...

    I hope you'll have some solution or idea what to try ...

    Item is visible on your tool, and ID of 765 is visible, that on someway gives me hope that item isn't totally lost ?!

    Yes, item was visible before by OS, just corrupted internal memory, but i didn't know for this tool HMPRERPUSB, and choose another way to solve that problem of corrupted internal memory by flashing firmware from SD CARD, and from that point, i get in troubles .

    Once tnx!

  6. #6
    Navigation software Moderator

    kunix's Avatar
    Join Date
    Sep 2011
    Location
    Belarus
    Posts
    658
    Likes (Given)
    85
    Likes (Received)
    965
    Dislikes (Given)
    1
    Dislikes (Received)
    0
    Rep Power
    141

    Default

    Tell me what happens if you do the following:
    0) Forcibly turn off the device by holding the power button.
    1) Flash the ORIGINAL firmware (after doing that, as I understand, the device doesn't reboot and the "Loader loading" message is displayed).
    2) Disconnect the device from the PC.
    3) Forcibly turn off the device by holding the power button.
    2) Connect the device to the PC.
    Last edited by kunix; 27-09-2012 at 11:06 AM.

  7. #7
    IGo Moderator Black Wolf's Avatar
    Join Date
    Jan 2010
    Location
    Near
    Posts
    312
    Likes (Given)
    172
    Likes (Received)
    4561
    Dislikes (Given)
    0
    Dislikes (Received)
    1
    Rep Power
    148

    Default

    1. Flashed with ORIGINAL firmware 2.50, this file nuvi7x5_regionfileonly__250.gcd, added in GarminCure folder, and selected "original" option, and then flashed with this original firmware, flashing finished OK, message "updating sucessfull", press ok, after finishig flashing, on screen of 765 is message "loader loading", and no rebooting.

    2. Disconnected device

    3. Turned off - forcibly, by pressing turn off button for 7 seconds, until it turned off.

    4. Connected device back to PC, and then stupid message "System Software Missing" , and i'm again in same loop, of trying to make visible device in storage mode to PC, that i can then update firmware by webupdater.

    Maybe i didn't do something good, pre-BOOT mode, i think can't get, but even that, GarminCure see this item without problem on USB port, and drivers for 765 device are installed, i tried on my laptop Win7 x64, on PC Win XP x86, same problem ...

    I don't have anymore idea, maybe to try making .RGN cure firmware from original, by removing 0x66 region, like you suggested for Kenwood where was same problem "loading loader" after flashin all time ?

  8. #8
    Navigation software Moderator

    kunix's Avatar
    Join Date
    Sep 2011
    Location
    Belarus
    Posts
    658
    Likes (Given)
    85
    Likes (Received)
    965
    Dislikes (Given)
    1
    Dislikes (Received)
    0
    Rep Power
    141

    Default

    It's not good that after successful flashing you still have system software missing.
    Try flashing this: www8.garmin.com/support/download_details.jsp?id=4357
    Also it doesn't have region 0x66 inside.

  9. #9
    IGo Moderator Black Wolf's Avatar
    Join Date
    Jan 2010
    Location
    Near
    Posts
    312
    Likes (Given)
    172
    Likes (Received)
    4561
    Dislikes (Given)
    0
    Dislikes (Received)
    1
    Rep Power
    148

    Default

    Ok, i'll check 4.50 version, version 2.50 has 0x66 region.

    *Update:

    Unfortunately with 4.50 it won't flash item with message "device is unable to program requested memory region" ?

    All firmwares to 3.60 version it flashs, but 3.90 and higher won't flash, with same message like for 4.50

    Anybody with some similary expirience, some suggestion, advice, what next to try or to bring it in trash ? Kunix is there any other what can i try ?
    Last edited by Black Wolf; 28-09-2012 at 08:36 AM.

  10. #10
    Moderator

    ddabcd277's Avatar
    Join Date
    Feb 2011
    Location
    At the moment-my body
    Age
    28
    Posts
    867
    Likes (Given)
    1219
    Likes (Received)
    1166
    Dislikes (Given)
    0
    Dislikes (Received)
    1
    Rep Power
    106

    Default

    Wanted to give this idea to Kunix. Hope he reads my comment. I read he made it on the firmware of other nuvis I think. And could be a solution to similar problems where there seems to be a partial damage of the the memory of the nuvi - the nuvi can be turned on, boot loader can be loaded, even the system firmware! but there is problem in the FS (0x48). Kunix can you prepare a tool where the system firmware does not read 0x48 but an SD card insted? Or this is not possible? Just nuvi to ignore reading from this part of the memory?

    BTW what is on 0x66? Why are you deleting it?
    Don't write me PMs for support. I will not answer!!! Make a topic in the proper section.
    Code:
    http://www.garminclub.bg/

 

 
Page 1 of 4 123 ... LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •