Welcome guest, is this your first visit? Click the "Create Account" button now to join.
Page 2 of 4 FirstFirst 1234 LastLast
Results 11 to 20 of 31
  1. #11
    Navigation software expert

    lolypop000's Avatar
    Join Date
    May 2010
    Location
    EU
    Posts
    2,925
    Rep Power
    848

    Default

    In 0x66 is text,keyboards etc.
    If you wann to nuvi read from SD then you must in FW, all 0:/ change to 1:/
    I repair my nuvi 1300 with this method when i have only preboot but pc dont recognize nuvi.
    I add all backup folder on SD and nuvi start,then i format nuvi and flash back original FW.
    Last edited by lolypop000; 1st October 2012 at 22:08.

  2.    Advertissements


  3. #12
    Navigation software Moderator

    kunix's Avatar
    Join Date
    Sep 2011
    Location
    Belarus
    Posts
    1,035
    Rep Power
    601

    Default

    sucro
    I'm sorry for not answering for too long. I was waiting for a notification, but the forum doesn't send notifications when some posts are edited.
    Let's try something else. Unpack the archive below to the root of an SD card; insert it; flash the RGN; post sd:/Garmin/Updater/0870/update.log here.
    [Only registered and activated users can see links. ]

    ddabcd277
    I was thinking about something like this some time ago. For example, we could let the bootloader read the firmware from the SD card instead of the ill region 14.
    But I think if one region fails then the others will fail soon, so we have to redirect all reads/writes to the SD card. And this is too complicated for me.
    Region 0x66 contains a ZIP file which is (supposedly) unpacked to the root of the internal filesystem. It seems that boot.bin can't flash this region when receiving it through USB. 0x66 should be unpacked from inside GCD only.

    lolypop000
    I was doing something like you've just described. Many file path are generated like sprintf(path, "%d:/Garmin/%s", drive, "blah/blah.blah"), so it's not enough to replace all occurences of "0:/" to "1:/" in the firmware. So I've tried to accomplish this by hooking the OpenFile function. But it didn't work, most of the files were not read from the SD card.
    Last edited by kunix; 1st October 2012 at 22:17.

  4. #13
    IGo Moderator Black Wolf's Avatar
    Join Date
    Jan 2010
    Location
    Near
    Posts
    436
    Rep Power
    353

    Default

    Thank you very much ddabcd for sharing your expirience and ideas , that together find some solution , specially with help of guru kunix ! I hope kunix will can prepare for me modified firmware for 765 nuvi, from thread with 765 firmwares posted by our dear catymag ...

    I think, cause kunix suggested in this post bellow for recovering Kenwood Garmin built-in gps navigation, that 0x66 region can cause that famous message "device is unable to program requested memory region""

    [Only registered and activated users can see links. ]

    it seems that helped to lucky guy with that device , but same thing didn't help my 765 , even i removed that 0x66 region...

    [Only registered and activated users can see links. ]

    It seems, problem on my nuvi 765 is more like one you described, with 0x48 problematic region...

    p.s.
    i found this about pk_files66.zip from nuvi's firmware,
    [Only registered and activated users can see links. ]

  5. #14
    Navigation software expert

    lolypop000's Avatar
    Join Date
    May 2010
    Location
    EU
    Posts
    2,925
    Rep Power
    848

    Default

    If you use rgn tool 0.87 and if you modify pk_files66.zip and add it back to gcd you will have pk_files66.zip (but this work only with 0.87)
    I have the same problem with kenwood when i try to modify pk_files66.zip and turboccc add this function in v0.87

    p.s.
    why you dont try flash with latest FW 4.50?

  6. #15
    IGo Moderator Black Wolf's Avatar
    Join Date
    Jan 2010
    Location
    Near
    Posts
    436
    Rep Power
    353

    Default

    Quote Originally Posted by kunix View Post
    sucro
    I'm sorry for not answering for too long. I was waiting for a notification, but the forum doesn't send notifications when some posts are edited.
    Let's try something else. Unpack the archive below to the root of an SD card; insert it; flash the RGN; post sd:/Garmin/Updater/0870/update.log here.
    [Only registered and activated users can see links. ]
    No problem man, thank you at all you answered, i know you are too much busy, probably by your private obligations, and manny by helping manny people here, we wait sometimes on you like on Santa ! So thank you very much! I'll try it now, i hope SD flashing will accept this problematic nuvi 765, cause after 1st flashin by SD Card method, it wouldn't flash anymore by SD Card, only by your great tool GarminCure3 via usb connection.

    I'll try it right now, and will inform you in new post, not in edited , so that you can recieve notification ...

  7. #16
    Navigation software expert

    lolypop000's Avatar
    Join Date
    May 2010
    Location
    EU
    Posts
    2,925
    Rep Power
    848

    Default

    When you flash over SD and when is finish you will see last_id.bin and if you dont remove it from SD you cant flash again with the same pack.

  8. #17
    IGo Moderator Black Wolf's Avatar
    Join Date
    Jan 2010
    Location
    Near
    Posts
    436
    Rep Power
    353

    Default

    Quote Originally Posted by lolypop000 View Post
    If you use rgn tool 0.87 and if you modify pk_files66.zip and add it back to gcd you will have pk_files66.zip (but this work only with 0.87)
    I have the same problem with kenwood when i try to modify pk_files66.zip and turboccc add this function in v0.87

    p.s.
    why you dont try flash with latest FW 4.50?
    Tnx for info lolly , you zmajchek :P ! I didn't modify pk_files66.zip, just removed, unticked that option for 0x66 region, like kunix suggested in thread for Kenwood, where you were included too .... You thoug RGN tool 0.78, cause latest official is 0.78, and beta is 0.84 ?

    [Only registered and activated users can see links. ]

    p.s.
    In this state of device, it accepts only firmwares 2.50 to 3.60 version, and them flashed ok, for some unkown reason firmwares from 3.90 to 4.50 can't be flashed in this state of device...

    It seems like something is related to 0x66, cause older versions like 2.50 to 3.60 have 0x66 region, and newer version 3.90-4.50 don't have 0x66 regions , pk_files66.zip, it seems this region is part of firmware where are located vpm files, cars, etc. , i'm not sure why they make problems for flashing, if make, kunix sure knows better , he suggested that to guy with kenwood, i described in previous post .

  9. #18
    Navigation software expert

    lolypop000's Avatar
    Join Date
    May 2010
    Location
    EU
    Posts
    2,925
    Rep Power
    848

    Default

    Here is v087:

    turboccc.wikispaces.com/file/view/RGN_Tool_V087.zip/293051720/RGN_Tool_V087.zip

    In your FW 2.50 you have only ExtData and RemoteSW.
    But in kenwood FW is voice,text..... and gir.img
    Last edited by lolypop000; 1st October 2012 at 22:58.

  10. #19
    IGo Moderator Black Wolf's Avatar
    Join Date
    Jan 2010
    Location
    Near
    Posts
    436
    Rep Power
    353

    Default

    Quote Originally Posted by kunix View Post
    sucro
    Let's try something else. Unpack the archive below to the root of an SD card; insert it; flash the RGN; post sd:/Garmin/Updater/0870/update.log here.
    [Only registered and activated users can see links. ]
    1. Flashing by SD CARD won't run

    2. Flashing by USB connection and your Garmin Cure3, was ok, at all there was message "update sucessfull", lime was with firmwares 2.50 to 3.60, this time suceed your modified 4.50 version, at all some progress, no anymore message "loader loading" after finished flashing ...

    One very strange thing, flashing took only 15-20 second at all, not 1 m 50 second like usually takes time for flashing ...

    I tried to disconnect device, and then to turn off, and then turn on, and again stupid message "system software missing" ..

    What to try now , to flash with 4.50 again - original ?

    Tnx!

  11. #20
    Navigation software expert

    lolypop000's Avatar
    Join Date
    May 2010
    Location
    EU
    Posts
    2,925
    Rep Power
    848

    Default

    Remove folder Garmin from your SD and extract rar that kunix send it to you and tri again flashing over SD.

    p.s.
    I create you FW 4.50 with pk_files66 inside.
    Try flash in pre boot.

    http://www29.zippyshare.com/v/65023470/file.html

 

 
Page 2 of 4 FirstFirst 1234 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
This website uses cookies
We use cookies to store session information to facilitate remembering your login information, to allow you to save website preferences, to personalise content and ads, to provide social media features and to analyse our traffic. We also share information about your use of our site with our social media, advertising and analytics partners.