Welcome guest, is this your first visit? Click the "Create Account" button now to join.
Page 2 of 2 FirstFirst 12
Results 11 to 12 of 12
  1. #11
    Member
    Join Date
    Sep 2011
    Location
    in a trailer by the river
    Posts
    19
    Rep Power
    0

    Default

    Garmin replaced my Nuvi 50 on warranty for this very problem. I had to pay shipping to them so it wasn't free.
    Looking back I am sure it was the 2.50 bad firmware that caused the problem.

  2.    Advertissements


  3. #12
    Junior Member
    Join Date
    Sep 2012
    Location
    nz
    Posts
    5
    Rep Power
    0

    Default

    Quote Originally Posted by lolypop000 View Post
    You can try with this:

    ***Hidden content cannot be quoted.***

    If you have win 7 make updater.exe compatible with win xp sp3 and then open as Administrator

    Now connect nuvi to pc and hold finger in uper left corner

    updater will recognice nuvi and you can flash to FW 2.60
    Thank you soooo much!!!! I think I was having problems with installing the device driver (after you run through the installer, when you plug it in and windows installs it). You are fantastic, thank you!
    Last edited by regularnoodle; 18th September 2012 at 09:53.

 

 
Page 2 of 2 FirstFirst 12

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
This website uses cookies
We use cookies to store session information to facilitate remembering your login information, to allow you to save website preferences, to personalise content and ads, to provide social media features and to analyse our traffic. We also share information about your use of our site with our social media, advertising and analytics partners.