Welcome guest, is this your first visit? Click the "Create Account" button now to join.
Page 1 of 2 12 LastLast
Results 1 to 10 of 14

Thread: Garmin 265wt

  1. #1
    Junior Member
    Join Date
    Aug 2012
    Location
    Hawthorne
    Posts
    6
    Rep Power
    0

    Default Garmin 265wt

    My garmin boots to white screen. My pc can recognise it, ican update on dashboard, and when it turns to the white screen, i can hear the touchscreen workin wheni press the screen. Can this be fixed or s this what they call "white screen brick"

  2.    Advertissements


  3. #2
    GPSPower Helper

    dasilvarsa's Avatar
    Join Date
    Feb 2011
    Location
    Global
    Posts
    1,160
    Rep Power
    351

    Default

    Do you see the Garmin Logo when you switch on ? Or Does it go directly to a bright white screen ?
    Do you see Loading Maps ?
    If you don't see anything at all on the screen maybe the screen is broken.
    What happened just before the white screen problem ?

  4. #3
    Junior Member
    Join Date
    Aug 2012
    Location
    Hawthorne
    Posts
    6
    Rep Power
    0

    Default

    It's just white screen. I have a working nuvi 1260 screen; I know it's smaller, but i tried swapping it with the nuvi 265wt and I still see white screen. When I first plugged it in, there was a GARMIN logo. I then updated from the mydashboard. It hasn't gone back to the Garmin Logo ever since.
    Last edited by pcmcia; 2nd September 2012 at 19:35.

  5. #4
    Navigation software expert

    lolypop000's Avatar
    Join Date
    May 2010
    Location
    EU
    Posts
    2,925
    Rep Power
    849

    Default

    Remove all from nuvi and add to backup

    Format nuvi and after format create empty folder Garmin

    Turn off and then on nuvi and look in folder Garmin if you have garmindevice.xml (if you have garmindevice.tmp rename it to .xml)
    Run webupdater and update all

    Now turn your nuvi on and will work.

  6. #5
    Junior Member
    Join Date
    Aug 2012
    Location
    Hawthorne
    Posts
    6
    Rep Power
    0

    Default

    I reformatted to FAT, did everything mentioned, and updated using mydashboard. I'm still getting the white screen. Anymore suggestions?

  7. #6
    GPSPower Helper

    dasilvarsa's Avatar
    Join Date
    Feb 2011
    Location
    Global
    Posts
    1,160
    Rep Power
    351

    Default

    Quote Originally Posted by pcmcia View Post
    I reformatted to FAT, did everything mentioned, and updated using mydashboard. I'm still getting the white screen. Anymore suggestions?
    Try to DownGrade the Firmware using Pre-Boot mode Updater.exe method . (Remove GUPDATE.GDC from Nuvi if it it in there)
    After Formatting My Dashboard will not upgrade the firmware because the Versions are the same.

  8. #7
    ☼ADMIN☼
    catymag's Avatar
    Join Date
    Nov 2007
    Location
    light side
    Posts
    23,642
    Rep Power
    5327

    Default

    I think you can try to remove the battery for a while, if this doesnt work ,I'm afraid there is nothing to do
    [Only registered and activated users can see links. ]
    [Only registered and activated users can see links. ]

    [Only registered and activated users can see links. ]
    You have to navigate to get to the good.
    Nuvi1250/Nuvi 34xx/Nuvi 2200/Nuvi 66/Oregon 600/Galaxy S5 MM 6.0.1/TomTom GO/iGO Nextgen Avic,Basar,Isr.Gift/Navigon
    Please don't flood my pm box with questions you can post on forum!! You won't hear back from me.

  9. #8
    Navigation software expert

    lolypop000's Avatar
    Join Date
    May 2010
    Location
    EU
    Posts
    2,925
    Rep Power
    849

    Default

    Go to preboot and flash with this:

    http://www3.zippyshare.com/v/29885927/file.html

  10. #9
    Junior Member
    Join Date
    Aug 2012
    Location
    Hawthorne
    Posts
    6
    Rep Power
    0

    Default

    Quote Originally Posted by catymag View Post
    I think you can try to remove the battery for a while, if this doesnt work ,I'm afraid there is nothing to do
    I have less than 10 posts; i cant see this. How long should i take out the battery?
    Last edited by pcmcia; 3rd September 2012 at 16:01.

  11. #10
    Junior Member
    Join Date
    Aug 2012
    Location
    Hawthorne
    Posts
    6
    Rep Power
    0

    Default

    How do you go to preboot. All i see is white screen

 

 
Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
This website uses cookies
We use cookies to store session information to facilitate remembering your login information, to allow you to save website preferences, to personalise content and ads, to provide social media features and to analyse our traffic. We also share information about your use of our site with our social media, advertising and analytics partners.