Welcome guest, is this your first visit? Click the "Create Account" button now to join.
Page 5 of 5 FirstFirst ... 345
Results 41 to 49 of 49
  1. #41
    Member TCIII's Avatar
    Join Date
    Apr 2010
    Location
    usa
    Posts
    23
    Rep Power
    14

    Default

    Thanks to ALL involved............Good Job!

  2.    Advertissements


  3. #42
    Master
    Join Date
    Feb 2011
    Location
    Sofia
    Age
    31
    Posts
    919
    Rep Power
    213

    Default

    Thanks Guys! Well, I was running blind here but ok. Glad to hear that the logo worked.

    So is the only difference that c0 byte (where I had d0)? what is it for and how did you figure it out?
    I didn't think much over it to be honest. I thought that the problem is coming from the programmer with which the dump was taken. Probably the programmer added some bytes and this is the reason why the picture is garbled. So for the creation of the Test logo I used the header plus 480x272x16 image plus the footer. Didn't change anything else.

    It shows fail on the system info for the logo....but is seems to work fine
    I thought I calculated the checksum. I think Turbo's GIR Editor calculates the right checksum if the image is passed through it.

    Update: If you have selected second image for the screen most probably you will have fail in the sys menu.

    Cheers,
    Last edited by ddabcd277; 24th April 2011 at 09:10.

  4. #43
    Navigation software expert turboccc's Avatar
    Join Date
    Aug 2010
    Posts
    377
    Rep Power
    123

    Default

    @snehne,

    yes, your D0 byte was wrong. It must be C0. This byte and the next is the width times 2 . So, if the width is 480, width * 2 = 960 which gives C0 03. I did not bother telling you since you told me the first logo was working well. I assumed the gps was not using it.
    [Only registered and activated users can see links. ]

  5. #44
    Master
    Join Date
    Feb 2011
    Location
    Sofia
    Age
    31
    Posts
    919
    Rep Power
    213

    Default

    @ Turboccc,

    Wanted to ask you something. Can you write how did you find possible Part Numbers (SKU's) of the logos in the fimwares? I read you know which strings describe them? Probably, the guys can unlock more futures from the upper models nuvi 670 and 680 like in 1xxx and 2xx series by changing a few numbers in the logo? ([Only registered and activated users can see links. ])

    Cheers and Happy Easter,
    Last edited by ddabcd277; 24th April 2011 at 15:42.

  6. #45
    Navigation software expert turboccc's Avatar
    Join Date
    Aug 2010
    Posts
    377
    Rep Power
    123

    Default

    @ddabcd277,

    You know more about me that I know myself... LOL! Seriously, I do not have this knowledge. There are reasons why the 1xxx models could be updated using the logo string, but I doubt this applies to the 6x0 models. If you want to try, you can make the string 5 or 6 characters and try. For example, the SKU is in the form of D0681-00 and only 681 is written. The 0 zeros seems to be removed or optional. Nothing prevents you from trying 68110 (D0681-10), 68160 (D0681-60), etc...

    Turbo
    [Only registered and activated users can see links. ]

  7. #46
    Master
    Join Date
    Feb 2011
    Location
    Sofia
    Age
    31
    Posts
    919
    Rep Power
    213

    Default

    @ Turbo

    I understand. I read your comments in the GIR Edtor thread regading the logo of 37xx and I thought...no matter...I don't have nuvi 600 so I leave this hint to the guys to try. May be an Eastern Bunny will jump out of this

    Cheers,

  8. #47
    Master
    Join Date
    Feb 2011
    Location
    Sofia
    Age
    31
    Posts
    919
    Rep Power
    213

    Default

    Quote Originally Posted by TCIII View Post
    It shows fail on the system info for the logo....
    Excuse me for writing one more time on this topic but now I figure something out that I think is important. Let me explain. The checksum of the logo I posted above was alright but the size of the logo not. This is the reason why even when the calculated end byte is correct on the system info it is still written fail. The size of the above logo is 262*146 bytes which can not be divided by 1024 exactly. Every garmin logo is closed by 1024 bytes. So the right size should be 262 144 bytes. Here it is I think the final version. There shouldn't be fail on the start up screen:
    [Only registered and activated users can see links. ]

  9. #48
    Navigation software expert turboccc's Avatar
    Join Date
    Aug 2010
    Posts
    377
    Rep Power
    123

    Default

    Hi ddabcd277,

    Which logo is this? The 6x0 or another 4:3 gps? That is a pretty small logo.

    Basically, you would like GIR_Editor to round the garmin logo size to a 1024-byte boundary. Correct? For some reason I would have thought GIR_Editor was doing that already, but it may be RGN_Tool. Let me know if I understand this correctly and I'll fix it.
    [Only registered and activated users can see links. ]

  10. #49
    Master
    Join Date
    Feb 2011
    Location
    Sofia
    Age
    31
    Posts
    919
    Rep Power
    213

    Default

    @ Turbo

    Yes, this is the logo of nuvi 6x0 series I posted above decreased by 2 bytes to be correct in size. (don't know is it compatible with other models) As I wrote I posted this corrected version because I figure out why the posted above logo showed fail in the system info on TCIII despite the fact that the end byte was correct. Don't know can GIR Editor or RGN Tolls understand and corrected if there is inaccuracy in the 1024-byte boundary but I have experimented with the logo of my C550, again ripped from a PouchX dump, made in the same way like the 600 series logo, and despite that it passed GIR Editor and RGN tool before I flashed it, it still showed fail in system info. So I need manualy decrese the size of the logo to pass the system info. Yeah, and after that I remeber the comment of TCIII and...etc. I think I used the latest versions of RGN Tool and GIR Editor. Sorry, I can't check that at the moment. Maybe GIR Editor or RGN Tool creates the correct 1024 bytes boundry if the logo is less in size but can't figure it out if it exceeds.

 

 
Page 5 of 5 FirstFirst ... 345

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
This website uses cookies
We use cookies to store session information to facilitate remembering your login information, to allow you to save website preferences, to personalise content and ads, to provide social media features and to analyse our traffic. We also share information about your use of our site with our social media, advertising and analytics partners.