Welcome guest, is this your first visit? Click the "Create Account" button now to join.
Results 1 to 4 of 4
  1. #1
    Junior Member
    Join Date
    Mar 2011
    Location
    At Home
    Posts
    7
    Rep Power
    0

    Default HELP: Garmin 295W Firmware

    Hi,

    Anyone know where I can get the original firmware for my Garmin 295W?

    I messed it up doing a patch and now it wont save any of the settings and asks for them every time I restart it or unplug it from USB mass storage mode.

    Or anyone know how to fix this other that re flashing?

    HELP!

  2.    Advertissements


  3. #2
    Master
    Join Date
    Feb 2011
    Location
    Sofia
    Age
    31
    Posts
    919
    Rep Power
    213

    Post

    Firmware (Linux ROM) of 295W not published at garmin site. Probably G60 ROM would help. Don't know. You can contact garmin support and ask to send it to you. Or search for Saniksanik2010 he can repair Linux based units even knows how to unlock Linux console. (paid)

    Just curious about the patch...What do you wanted to do?
    Last edited by ddabcd277; 20th March 2011 at 08:49.

  4. #3
    Junior Member
    Join Date
    Mar 2011
    Location
    At Home
    Posts
    7
    Rep Power
    0

    Default

    Hi ddabcd277,

    I was fiddling around with it trying to get into pre-boot mode. I touched the battery icon and got into a diagnostics menu, one of the items there was called "Flash Firmware", I touched it, expecting another menu, but no, it went to the progress bar and started flashing.

    I later figured out, that there was a file in the device's RemoteSW folder called 006B100800.bin, so that's probably the file it used to flash. And when I remove that file and go through the procedure again, nothing happens.

    That file came with the device from the factory, I didn't put it there. I know this because the day I got my 295W, I immediately backed up the contents of the Garmin drive.

    Looks like it's for a different HWID, mine has HWID of <PartNumber>006-B0904-07</PartNumber>

    This is driving me nuts, it works fine routing wise.

    Do you have a link of the G60 ROM?

  5. #4
    Master
    Join Date
    Feb 2011
    Location
    Sofia
    Age
    31
    Posts
    919
    Rep Power
    213

    Default

    Files in the folder RemoteSW are not the firmware of the unit. Probably firmware of the Bluetooth, traffic receiver etc.

    Here what my suggestions are:
    1. Delete (first make a backup) of the file GarminDevice.xml from the unit memory. Unplug and then turn the device on. If you connect it again to PC you should have created again the file GarminDevice.xml.
    2. After that start WebUpdater. Most probably the program will allow you to download again the missing firmware (file).
    3. Go outside with the unit and acquire satellite signal.

    Cheers,
    Last edited by ddabcd277; 20th March 2011 at 19:04.

 

 

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
This website uses cookies
We use cookies to store session information to facilitate remembering your login information, to allow you to save website preferences, to personalise content and ads, to provide social media features and to analyse our traffic. We also share information about your use of our site with our social media, advertising and analytics partners.