Hello everyone,

So far I was using Garmin SP Onboard 2.0 as of one of the last versions that could use custom maps and because I have managed to run Garmin StreetPilot NA 2.7 but the downloaded in-app map was 2013.10 when the newest were 2015.10 so I thought to wait for 2.8 and see it from there.

Today a friend of mine shared with me a link from which I have managed to download the 2.8 North America ipa file and it was about the time to test it.

As always, I did block the gold.garmin.com using FirewallIP on my jailbroken iPhone 4 and as I expected the app started fine and offered me to download the base files + selected map. It downloaded everything fine, afterwhat offered me to restart the application so to have the new files in place and loaded. After the restart, however I received a message stating that I need an Internet connection to verify the license of the maps.

I cannot find my notes about how I got 2.7 working but as far as I remember I did nothing different but to block the gold.garmin.com in my firewall application.

The strange and funny thing is that after removing the application and reinstalling it again, I received the well known error for any versions above 2.3.4 - Authentication Failure - Please verify you have downloaded the latest version of the application from the App Store.

The odd thing in my case is that I have managed to install the app and download the Full North America img map + jcv + basemap etc. and I can attach them here or in another link and post the url, however suddenly after the restart the app is showing the Authentication Failure.

Any ideas, experiences with StreetPilot above 2.4 and the both mentioned errors are highly appreciated.

I do not know is it allowed to post links to file sharing hosts, however I am not the author nor related to any generated revenues so attaching it just for testing purposes. I guess that should be OK

Code:
Please Login or Register to see the links