Hi guys,

I'm facing a really big problem with my 276c Arabic Garmin software, the problem is that i can't install the new maps ( NT type) because of my old software (version : 2.01).Moreover, i tried updating the software many times but i couldn't because the webupdater says that there is no new update for my software. As a last step i took the Garmin to the local dealer hopping that he has a solution for this problem but even the dealer couldn't do anything about it.

i hope to find a solution here