Welcome guest, is this your first visit? Click the "Create Account" button now to join.
Results 1 to 7 of 7
  1. #1
    Junior Member
    Join Date
    Apr 2015
    Location
    Montenegro
    Posts
    5
    Rep Power
    0

    Triangle Garm. Garmin Astro 320 weird problem, help needed.

    Ok here is the problem.
    Last night a friend brought his Astro 320 US edition to downgrade the firmware to 3.40 so that he can use Radio Function here in Europe.
    When I downgraded firmware screen rotates 180 degrees and moves a bit to the left leaving blank space on the left side of screen (colors are also different like blue is red now). Also when booting it doesn't show Astro 320 but Astro?, in Webupdater it also shows device model as Astro?. I have already downgraded more than 50 Astro 320 devices and never seen anything like this before, so if anyone know something about this please tell me what can I do, except returning this device to GARMIN?

  2.    Advertissements


  3. #2
    Navigation software expert

    Ellinas's Avatar
    Join Date
    May 2011
    Location
    Greece
    Posts
    651
    Rep Power
    545

    Default

    Please read here: [Only registered and activated users can see links. ]
    [Only registered and activated users can see links. ]

  4. #3
    Member
    Join Date
    Jul 2015
    Location
    china
    Posts
    16
    Rep Power
    0

    Default

    I have a astro 320 armed with the same problems Ask each ace to help me to solve grateful!

  5. #4
    Member
    Join Date
    Jul 2015
    Location
    china
    Posts
    16
    Rep Power
    0

    Default

    Problem has been resolved

  6. #5
    Member
    Join Date
    Jul 2015
    Location
    china
    Posts
    16
    Rep Power
    0

    Default

    I don't know why problem repeat again

  7. #6
    Junior Member
    Join Date
    Nov 2016
    Location
    Dinaric Alps
    Posts
    2
    Rep Power
    0

    Unhappy astro 320 Display upside down and shiftted after downgrading to 3.40 HELP needed

    Hallo friends

    After downgrading my US Astro 320 with Garmicure3 and updater exe to version 3.40 I got display upside down and shiffted 8mm left.

    I have tried installing 133901000430.rgn but the same reapiered after installation is over?

    Please help
    What am I doing wrong?
    And are this 2015 Astro 320 v4.40 downgradebale to 3.40 at all?

    Please help

    Thanks

  8. #7
    Junior Member
    Join Date
    Nov 2016
    Location
    Dinaric Alps
    Posts
    2
    Rep Power
    0

    Default

    OOOOPPPS

    It works now.
    That patched version 4.30 133901000430.rgn seems to work fine. I have just tested it on the field and it works fine.

    Just to resume that i failed to downgrade with Webupdated but seccede with GarminCure3 and updated.exe!
    Webupdated steps was HUGE waste of time in my case.
    Garmincure3 solved and issue in 30 mins.

    Very best regards
    Ivan From Croatian Dinaric alps

 

 

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
This website uses cookies
We use cookies to store session information to facilitate remembering your login information, to allow you to save website preferences, to personalise content and ads, to provide social media features and to analyse our traffic. We also share information about your use of our site with our social media, advertising and analytics partners.