Welcome guest, is this your first visit? Click the "Create Account" button now to join.
Results 1 to 4 of 4
  1. #1
    Junior Member
    Join Date
    Oct 2015
    Location
    colorado
    Posts
    2
    Rep Power
    0

    help Garmin Edge 605 - Stuck at Locating Satellites

    Hi All:

    New member here. I have a garmin edge 605 that I have revived (mostly) from rain exposure. It was dropped on a trail and was in the rain/moisture for at least 2 days. I got it cleaned up and it will start up, but it gets stuck at the locating satellites screen, with the bar going maybe 1/4 across the screen before restarting. I have left it out for 2 hours, with no change.

    Steps that I have done so far:
    1. replaced the battery - old one was trashed
    2. hard reset
    3. downloaded the latest software via web updater.
    4. cleaned out all old files (.tcx) and history files

    not sure if this is a software problem that can be fixed or if there is an issue with the chipset or antenna. I have searched google for this problem and it seems to never have been solved except for sending back to garmin. Any thoughts? Appreciate any help.

    this site is a fantastic resource. I have about 10 Garmin devices and nice to have a place to go for help!

  2.    Advertissements


  3. #2
    ☼ADMIN☼
    catymag's Avatar
    Join Date
    Nov 2007
    Location
    light side
    Posts
    23,642
    Rep Power
    5327

    Default

    From Garmin FAQ:
    Why won't my Edge or Forerunner lock on to satellites?
    Occasionally an Edge or Forerunner may have trouble acquiring satellites. This may be due to corrupted satellite information. Performing an AutoLocate will clear previous GPS data and allow the device to reacquire the satellite information.

    You may need to perform an AutoLocate in the following circumstances:

    Device has not been used in over two weeks
    Device has travelled more than 150 miles between satellite acquisitions
    Distance or speed data appear to be inaccurate

    Edge 605/705:

    Ensure device is powered off
    Press and hold "out"
    Press and release power
    Wait 30 seconds
    Release "out"

    Code:
    Please Login or Register to see the links
    Code:
    Please Login or Register to see the links
    Try and good luck
    [Only registered and activated users can see links. ]
    [Only registered and activated users can see links. ]

    [Only registered and activated users can see links. ]
    You have to navigate to get to the good.
    Nuvi1250/Nuvi 34xx/Nuvi 2200/Nuvi 66/Oregon 600/Galaxy S5 MM 6.0.1/TomTom GO/iGO Nextgen Avic,Basar,Isr.Gift/Navigon
    Please don't flood my pm box with questions you can post on forum!! You won't hear back from me.

  4. #3
    Junior Member
    Join Date
    Oct 2015
    Location
    colorado
    Posts
    2
    Rep Power
    0

    Default

    Hi, I tried all the suggestions and its still stuck at locating satellites. Am I supposed to see a different dialogue after the 30 seconds? all other functions seem to be working.

  5. #4
    ☼ADMIN☼
    catymag's Avatar
    Join Date
    Nov 2007
    Location
    light side
    Posts
    23,642
    Rep Power
    5327

    Default

    If it's a software corruption problem you can try a couple of options:
    1)Downgrade firmware to a previous firmware and then reinstall the current. Downgrading it will clear NV completely.
    2)Backup Edge content on pc, then format it as FAT32 following this thread:
    [Only registered and activated users can see links. ]
    Remove the SD card if present before formatting.
    When done, create a new folder named "Garmin" in the newly formatted drive. Restart it and run Webupdater. Add missing files from backup, don't add back Courses and Activities files and any personal data files.
    [Only registered and activated users can see links. ]
    [Only registered and activated users can see links. ]

    [Only registered and activated users can see links. ]
    You have to navigate to get to the good.
    Nuvi1250/Nuvi 34xx/Nuvi 2200/Nuvi 66/Oregon 600/Galaxy S5 MM 6.0.1/TomTom GO/iGO Nextgen Avic,Basar,Isr.Gift/Navigon
    Please don't flood my pm box with questions you can post on forum!! You won't hear back from me.

 

 

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
This website uses cookies
We use cookies to store session information to facilitate remembering your login information, to allow you to save website preferences, to personalise content and ads, to provide social media features and to analyse our traffic. We also share information about your use of our site with our social media, advertising and analytics partners.