Welcome guest, is this your first visit? Click the "Create Account" button now to join.
Page 1 of 2 12 LastLast
Results 1 to 10 of 16
  1. #1
    Member + mallard2's Avatar
    Join Date
    Jul 2013
    Location
    United Kingdom
    Posts
    81
    Rep Power
    4

    Default 3790LMT garmin express map updates

    Hi all,
    Back from my Aussie Holiday ......back into the sat nav now ,However .......

    When I try to update my 3790LMT ( presently has 2015.10 )with GE , it tells me all is up todate !
    Then I tried with Mapupdater & that tells me an update is available for purchase !

    I understand that 2015.20 is available & it must be, for Map updater to tell me an update is available for purchase !!

    I don't have a problem really because I can get the updates from here , just confused as to why this is happening ??

    Any advice would be appreciated

    regards

  2.    Advertissements


  3. #2
    GPSPower Helper

    dasilvarsa's Avatar
    Join Date
    Feb 2011
    Location
    Global
    Posts
    1,160
    Rep Power
    351

    Default

    Have you updated Garmin Express ?
    I had a similar problem a while back but the problem was on the Garmin Server. (one of the xml files had incorrect information)
    The difference between stupidity and genius is that genius has its limits.
    Albert Einstein.

  4. #3
    Member + mallard2's Avatar
    Join Date
    Jul 2013
    Location
    United Kingdom
    Posts
    81
    Rep Power
    4

    Default

    Hi
    Thanks for the prompt reply ,

    yes I did update GE ( it asked to update when I ran it)

    Cheers

  5. #4
    Garmin/GPS Systems GMod.

    Neil's Avatar
    Join Date
    Aug 2011
    Location
    Oz.
    Posts
    7,401
    Rep Power
    1434

    Default

    G'day again Ducky. Hope we were kind to you downunder [lucky you missed Arbor Day aka 'Plant-a-Pom Day' in some parts of Oz].

    You had that or a similar problem before i recall: [Only registered and activated users can see links. ]. Same unit? I also recall you have 2 x 3790s.

    sedra had a problem with an EU 3590 which he thought was LM but it seems it wasn't. In Post #13 of [Only registered and activated users can see links. ] i gave him some things to try, maybe you could check that out and if it's no help post some screenshots of GarminExpress/MapUpdater with the 3790 connected. Early 3790's were sold worldwide as non-LM. If you have it registered, myGarmin/myMaps will show for sure if Garmin thinks it's LM. If it's not showing as LM and you're convinced it is then ring UK support. Don't bother with email 'coz from what i've heard it seems that they pretty much ignore them, but their phone service is reportedly very good.

    EDIT: Here's another quick way to check if Garmin has it listed as an LM or not. Without the unit connected to the PC, go to Garmin Map Updates:
    Code:
    Please Login or Register to see the links
    Fill in the Serial Number above the 'Find Map Updates' button. On the next page if you see the first screen below telling you to use GE to manage your maps then it's an LM unit, but the second screen trying to sell you a new map means it's not LM according to Garmin:

    [Only registered and activated users can see links. ] [Only registered and activated users can see links. ]
    Last edited by Neil; 15th August 2014 at 00:44.
    'Thanking Posts' are banned. To thank someone, and/or to see hidden links and content, use the [Only registered and activated users can see links. ] button below left of the helpful post then refresh your browser [F5 key]. 'Thanking Posts' are banned.
    Please don't spam. Posts serving no purpose other than to thank or to ask about hidden links are trashed or deleted, it's GPSPower's policy. Please don't spam.
    [Only registered and activated users can see links. ] should make their first post as a new Intro Thread in [Only registered and activated users can see links. ].

  6. #5
    Member + mallard2's Avatar
    Join Date
    Jul 2013
    Location
    United Kingdom
    Posts
    81
    Rep Power
    4

    Default

    Hi Neil,
    My memory fails me ,but yes I did have 2 x 3790 ...one is now resident in Aus with my son !! & I believe this is the same unit that I posted about earlier ,but I never resolved it .

    I checked via your link & Garmin tells me it is an LMT

    [Only registered and activated users can see links. ]

  7. #6
    Garmin/GPS Systems GMod.

    Neil's Avatar
    Join Date
    Aug 2011
    Location
    Oz.
    Posts
    7,401
    Rep Power
    1434

    Default

    Did you add the unicode 2015.10 from here? If so, maybe your problem is that some early EU/UK 3790LM had the non-unicode EU/Regional as OEM. Therefore your unit may be 'up to date' in the sense that 2014.40 is the current non-U. Have you checked in myMaps as suggested in [Only registered and activated users can see links. ] of that other thread? You might need to first register it in myGarmin if you haven't done so yet.
    'Thanking Posts' are banned. To thank someone, and/or to see hidden links and content, use the [Only registered and activated users can see links. ] button below left of the helpful post then refresh your browser [F5 key]. 'Thanking Posts' are banned.
    Please don't spam. Posts serving no purpose other than to thank or to ask about hidden links are trashed or deleted, it's GPSPower's policy. Please don't spam.
    [Only registered and activated users can see links. ] should make their first post as a new Intro Thread in [Only registered and activated users can see links. ].

  8. #7
    Member + mallard2's Avatar
    Join Date
    Jul 2013
    Location
    United Kingdom
    Posts
    81
    Rep Power
    4

    Default

    Hi Neil,
    Yes I updated it from This site & I have also registered it with Garmin ................
    Still not showing update options available or re-install map etc,etc

    Confused but persevering

  9. #8
    Garmin/GPS Systems GMod.

    Neil's Avatar
    Join Date
    Aug 2011
    Location
    Oz.
    Posts
    7,401
    Rep Power
    1434

    Default

    Do you have a backup from when you bought it to check if OEM map version was Unicode or not?

    Otherwise, go to the map Updates page again this time with the 3790 connected and click 'Device Content'. If it has OEM non-unicode it will show 'Europe NT' like the first screen below, if unicode it will be 'Europe NTU' as in the second for the dezl 760:

    [Only registered and activated users can see links. ] [Only registered and activated users can see links. ]
    'Thanking Posts' are banned. To thank someone, and/or to see hidden links and content, use the [Only registered and activated users can see links. ] button below left of the helpful post then refresh your browser [F5 key]. 'Thanking Posts' are banned.
    Please don't spam. Posts serving no purpose other than to thank or to ask about hidden links are trashed or deleted, it's GPSPower's policy. Please don't spam.
    [Only registered and activated users can see links. ] should make their first post as a new Intro Thread in [Only registered and activated users can see links. ].

  10. #9
    Member + mallard2's Avatar
    Join Date
    Jul 2013
    Location
    United Kingdom
    Posts
    81
    Rep Power
    4

    Default

    Hi Everybody ,
    Sorry about the delay in replying but my PC "died" ..... have now got a new laptop and in the process of updating everything & installing drivers .............

    Anyhow, re my 3790lmt ,I went to the device content and all it showed were the words " MPC map", so I am totally confused ,the unit has NTU maps installed & the "my Gamin" page shows it as a 3790 LMT ??

    Any help is appreciated ,(but replies may be delayed a while ,until I have everything re-instaalled and up to date)

    Best Regards

  11. #10
    Garmin/GPS Systems GMod.

    Neil's Avatar
    Join Date
    Aug 2011
    Location
    Oz.
    Posts
    7,401
    Rep Power
    1434

    Default

    Connect it with GarminExpress and see what it offers. Remove any 'unofficial' map first though. Do you have a backup to confirm which map [U or non-U] was loaded when you bought it? You've said it has NTU installed now, but we need to know what's the OEM, U or non-U.
    'Thanking Posts' are banned. To thank someone, and/or to see hidden links and content, use the [Only registered and activated users can see links. ] button below left of the helpful post then refresh your browser [F5 key]. 'Thanking Posts' are banned.
    Please don't spam. Posts serving no purpose other than to thank or to ask about hidden links are trashed or deleted, it's GPSPower's policy. Please don't spam.
    [Only registered and activated users can see links. ] should make their first post as a new Intro Thread in [Only registered and activated users can see links. ].

 

 
Page 1 of 2 12 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
This website uses cookies
We use cookies to store session information to facilitate remembering your login information, to allow you to save website preferences, to personalise content and ads, to provide social media features and to analyse our traffic. We also share information about your use of our site with our social media, advertising and analytics partners.