Welcome guest, is this your first visit? Click the "Create Account" button now to join.
Results 1 to 8 of 8
  1. #1
    Member +
    Join Date
    Nov 2009
    Location
    Rio de Janeiro
    Age
    70
    Posts
    75
    Rep Power
    9

    ? Garmin 3790T powering off and back on

    Need help, folks

    I left my my nüvi 3790T unused for a couple of months, the battery almost zeroed.

    I recharged it to 100%, all seemed fine and I started using it in may car normally.

    However, when in normal operation, all of a sudden pops up the message EXTERNAL POWER LOST, TURNING OFF IN 15 SECONDS.

    It turns itself OFF and, after a few seconds, it is back on again. I tried unplugging and plugging back on on the cigarette ligther (which I use for other devices, so it is OK).

    The device was never dropped to the ground, was stored in a case. I'm planning a long trip and would like to have it in good working condition.

    Does anyone has any idea on what can I do ?
    ============
    Carlos Magalhaes
    Garmin nüvi 3790T

  2.    Advertissements


  3. #2
    Garmin/GPS Systems GMod.

    Neil's Avatar
    Join Date
    Aug 2011
    Location
    Oz.
    Posts
    7,400
    Rep Power
    1434

    Default

    Try cleaning both the unit's contact points, the cradle's usb port and the charger's usb plug with contact cleaner. It seems that the charger is 'making & breaking'.
    'Thanking Posts' are banned. To thank someone, and/or to see hidden links and content, use the [Only registered and activated users can see links. ] button below left of the helpful post then refresh your browser [F5 key]. 'Thanking Posts' are banned.
    Please don't spam. Posts serving no purpose other than to thank or to ask about hidden links are trashed or deleted, it's GPSPower's policy. Please don't spam.
    [Only registered and activated users can see links. ] should make their first post as a new Intro Thread in [Only registered and activated users can see links. ].

  4. #3
    Member +
    Join Date
    Nov 2009
    Location
    Rio de Janeiro
    Age
    70
    Posts
    75
    Rep Power
    9

    Default

    Thank you.

    I will get a contact cleaner and give it a try.
    ============
    Carlos Magalhaes
    Garmin nüvi 3790T

  5. #4
    Member + karaoke's Avatar
    Join Date
    Sep 2010
    Location
    earth
    Posts
    82
    Rep Power
    41

    Default

    have u try to replace battery yet?

  6. #5
    Garmin/GPS Systems GMod.

    Neil's Avatar
    Join Date
    Aug 2011
    Location
    Oz.
    Posts
    7,400
    Rep Power
    1434

    Default

    Easy way to check if the battery is u/s, just unplug the charger and cancel the auto shutdown. If the unit runs on battery power for a fair while it's ok. [3790 can run for up to 4 hrs if 100% charged depending on load].
    'Thanking Posts' are banned. To thank someone, and/or to see hidden links and content, use the [Only registered and activated users can see links. ] button below left of the helpful post then refresh your browser [F5 key]. 'Thanking Posts' are banned.
    Please don't spam. Posts serving no purpose other than to thank or to ask about hidden links are trashed or deleted, it's GPSPower's policy. Please don't spam.
    [Only registered and activated users can see links. ] should make their first post as a new Intro Thread in [Only registered and activated users can see links. ].

  7. #6
    Member +
    Join Date
    Nov 2009
    Location
    Rio de Janeiro
    Age
    70
    Posts
    75
    Rep Power
    9

    Default

    Yes, I use it indoors for testing and inserting addresses and it works fine.
    ============
    Carlos Magalhaes
    Garmin nüvi 3790T

  8. #7
    Garmin/GPS Systems GMod.

    Neil's Avatar
    Join Date
    Aug 2011
    Location
    Oz.
    Posts
    7,400
    Rep Power
    1434

    Default

    Then the problem is not with the battery, it's either the charger itself or more likely the connections as i originally suggested. Have you tried the contact cleaner spray yet?
    'Thanking Posts' are banned. To thank someone, and/or to see hidden links and content, use the [Only registered and activated users can see links. ] button below left of the helpful post then refresh your browser [F5 key]. 'Thanking Posts' are banned.
    Please don't spam. Posts serving no purpose other than to thank or to ask about hidden links are trashed or deleted, it's GPSPower's policy. Please don't spam.
    [Only registered and activated users can see links. ] should make their first post as a new Intro Thread in [Only registered and activated users can see links. ].

  9. #8
    GPSPower Helper

    dasilvarsa's Avatar
    Join Date
    Feb 2011
    Location
    Global
    Posts
    1,160
    Rep Power
    351

    Default

    I would try another Charger. Does not need to be traffic receiver. (one from a 1xxx works in 3790 mount)
    Sounds like the charger is going into protection and then recovering again (not strong enough for the load).
    The nuvi thinks you've switched off your ignition but it knows that it is in the mount.
    The difference between stupidity and genius is that genius has its limits.
    Albert Einstein.

 

 

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
This website uses cookies
We use cookies to store session information to facilitate remembering your login information, to allow you to save website preferences, to personalise content and ads, to provide social media features and to analyse our traffic. We also share information about your use of our site with our social media, advertising and analytics partners.