Welcome guest, is this your first visit? Click the "Create Account" button now to join.
Likes Likes:  0
Results 1 to 3 of 3
  1. #1
    Junior Member
    Join Date
    May 2010
    Location
    Massachsuetts
    Posts
    6
    Rep Power
    0

    Default 1450LMT navigation screen weirdness

    Hi everyone,

    I have a 1450LMT and noticed that the navigation map sometimes acts weird. Some symptoms are:

    1. current speed doesn't update
    2. instead of displaying time of arrival, it displays current heading

    Everything goes back to normal if I press the back arrow and then go back to the navigation screen again.

    Unit is running North America 2013.20 with all the latest updates from Garmin.

    Thanks!

  2.    Advertissements


  3. #2
    Navigation software expert

    lolypop000's Avatar
    Join Date
    May 2010
    Location
    EU
    Posts
    2,925
    Rep Power
    849

    Default

    This is happened sometimes on 1xxx series, clear non vol is answer

  4. #3
    Junior Member
    Join Date
    May 2010
    Location
    Massachsuetts
    Posts
    6
    Rep Power
    0

    Default

    Quote Originally Posted by lolypop000 View Post
    This is happened sometimes on 1xxx series, clear non vol is answer
    Thanks. I cleared after the last upgrade but I just wanted to find out if this was unique to me.

 

 

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
This website uses cookies
We use cookies to store session information to facilitate remembering your login information, to allow you to save website preferences, to personalise content and ads, to provide social media features and to analyse our traffic. We also share information about your use of our site with our social media, advertising and analytics partners.