Welcome guest, is this your first visit? Click the "Create Account" button now to join.
Page 1 of 3 123 LastLast
Results 1 to 10 of 22
  1. #1
    Global Moderator

    smokefree's Avatar
    Join Date
    Sep 2010
    Location
    @ home
    Age
    36
    Posts
    3,298
    Rep Power
    717

    topo ActiveRouting .db file - general discussion

    With the introduction of the topo PRO maps by Garmin, also ActiveRouting has been introduced. Spread over various threads, related information can be found but member results are not consistent. Some get it to work on their GPS unit but not in BaseCamp, some get it to work the other way around, and some don't get it to work at all. And if it works in BaseCamp with one map, it may not work the same way with another map. Since the information is scattered over various topo PRO threads, it is not easy to get a grip on the problem. Therefore I started this thread to focus on the issue and have the discussion about the ActiveRouting file in one location.

    A few things that puzzle me:

    In one of the threads, I noticed the screen shot below, showing the files in the SD:\Garmin\SQL folder of a (genuine) downloaded version of Topo Austria v3:

    xqz1T

    Note that one zero of the .DB file name is left out at the end in the .UNL file name as well as in the .GMA file name. I assume that's how it is supposed to be. But then, how would that work with the .DB file of for instance Topo Germany 2012 PRO which has the file name 010-D0752-01.db?
    Would the .UNL file be named 010-D0752-01.UNL or 010-D0752-0.UNL or 010-D0752-1.UNL???

    Some members reported the need for an .UNL file to make it work on their GPS, others say it works without .UNL as well. How can that be explained?

    Unfortunately, I don't have a hand-held GPS unit myself (sometimes can borrow from a friend at the other end of the country who I don't see regularly), so I can't try out different setups on the GPS myself. Therefore I welcome any input, feedback, suggestions, comments, experiences, etc on this issue and hope the fog that surrounds the ActiveRouting file eventually clears up.
    Last edited by Ballebar; 20th September 2012 at 21:52. Reason: Changed title from "ActiveRouting .bd file - general discussion" to "ActiveRouting .db file - general discussion"

  2.    Advertissements


  3. #2
    ☼ADMIN☼
    catymag's Avatar
    Join Date
    Nov 2007
    Location
    light side
    Posts
    23,573
    Rep Power
    5313

    Default

    We can copy here the interesting posts from Topo pro maps thread

    Quote Originally Posted by GPSFranz View Post
    I am getting closer to figuring out what is going on

    So far, I know how to enable searching for 'Named Trails' in BaseCamp 3.3.3 for Topo Austria v3 (locked IMG file).
    (The following header information for the IMG files is from GMapTool.)

    Header: 11.06.2012 13:38:32, DSKIMG, XOR 00, V 3.00, Ms 0, 010-D1199-00
    Mapset: Topo Österreich v3
    Please note the name of the 010-D1199-00.db file in the header.

    For TransAlpin 2012 Pro it is not working (it may have to do with the missing name of the 010-D1160-00.db file in the header).
    Header: 25.05.2012 21:58:23, DSKIMG, XOR 00, V 3.00, Ms 0
    Mapset: TransAlpin 2012 Pro

    The question now is:
    Why is the name of the 010-D1160-00.db file in the header of TransAlpin 2012 Pro missing in my IMG file?
    Is it because my file (I am quite sure I downloaded it from the Zippyshare links in catymag's post #2) is NOT an original locked IMG file?

    Please check the header information of your TransAlpin 2012 Pro IMG file with GMapTool (to see if the name of the 010-D1160-00.db file in the header is missing or not).
    It would be nice to solve this problem.
    Quote Originally Posted by Ballebar View Post
    The NamedTrails SQLite DB file is named as the part number for the map.
    TransAlpin 2012 Pro (Download) with part number 010-D1160-00 is using SQLite file 010-D1106-00.db.
    Quote Originally Posted by catymag View Post
    The .img isnt original coz personal unlock codes were removed with pietu's tool: it contains GMT.exe old version.


    Quote Originally Posted by merlinboy View Post
    Ok, if the part number of the map (which also defines the name of the SQL file) has been removed, we have to insert it again. Take a hexeditor and insert the following hexadecimal values beginning at position 48 (hex 0x30):

    Code:
    Please Login or Register to see the links
    [Only registered and activated users can see links. ]

    GMapTool info will now look like

    Code:
    Please Login or Register to see the links
    and NamedTrails are working now in my unlocked image.
    Quote Originally Posted by merlinboy View Post
    And the same procedure for Topo Austria v3. Take a hexeditor and insert the following hexadecimal values beginning at position 48 (hex 0x30):

    Code:
    Please Login or Register to see the links
    [Only registered and activated users can see links. ]

    GMapTool info will now show

    Code:
    Please Login or Register to see the links
    and NamedTrails are also working now in this unlocked image.
    Quote Originally Posted by merlinboy View Post
    so I can also add the values for the mentioned Topo France Sud-Est:

    Code:
    Please Login or Register to see the links
    GMapTool info will now show

    Code:
    Please Login or Register to see the links
    and NamedTrails are also working now in this unlocked image.
    Quote Originally Posted by merlinboy View Post
    and finally Topo Deutschland 2012 Pro, which is said to have the same problems:

    Code:
    Please Login or Register to see the links
    GMapTool info will now show

    Code:
    Please Login or Register to see the links

    Quote Originally Posted by jonnywi View Post
    here is the screenshot of basecamp 4.0.0.5 beta
    [Only registered and activated users can see links. ]

    Quote Originally Posted by syzygy View Post
    For original locked img files, gimgunlock does not change the header, so the part number should remain the same in header and the unlocked img files should still have "Named Trails". For an existing unlocked img file without part number, all you need is to write a separate tool to open the img file, fseek to offset 48 (0x30 in hex), write 9 bytes of compressed part number there, then close the file. It should be easy to do in Perl or C/C++.
    Quote Originally Posted by sherco40 View Post
    I have implemented this functionality (i.e. display and change of the img part number) in [Only registered and activated users can see links. ].

    It is in french...( open your img and click on "Changer le numéro de produit du fichier img")

    Please, if you want to try it, back up your img before...

    For me it works fine with topo Germany, Austria and France...

    Quote Originally Posted by merlinboy View Post
    Here is a Perl script to change or add the part number in an image file. It works an a Windows system with Perl installed or of course on a Linux system:

    [Only registered and activated users can see links. ]

    The script takes two parameter, which can be changed in the script - see the marked lines in the first part):

    - the name of the image file (default: 'imagefile.img', as you always should worked with a copy)

    - the part number as normal string like '010-D1160-00' for Transalpin 2012 Pro (default: empty string).

    The part number will be coded (second part) and the resulting 9 bytes are written into the imagefile (third part), beginnend at position 48 (hex 0x30).

    Quote Originally Posted by catymag View Post
    SQLbrowser to open these files:
    Code:
    Please Login or Register to see the links
    Quote Originally Posted by Mapperoni View Post
    These are my findings so far:

    • When Topo Austria v3 is the only map on SD I can search and find Trails and they are highlighted violet (as usual) when selected. When just looking at the map NO trails are highlighted (red or purple), whatever activity is chosen.
    • Whe I add Topo France v3 on SD I can't find any trail in Austria anymore. Only French trails can be found.
    • I didn't try TransAlpine and Austria together yet but I would expect problems since they are covering the same area partially.
    • Maybe Catymag is right stating these maps are meant to be used as a single product on a single SD card.

    Quote Originally Posted by federbruch View Post
    According to the german garmin forum, more than one db file on an oregon or a montana don`t work.
    The mod has informed the developers about this issue.

    Quote Originally Posted by MaxDoe View Post
    Extensive testing now shows the following for me:

    1. only Transalpine (+SQL) on SD
      • colour highlighting works
      • trail search works
      • this is expected behaviour
    2. only Austria v3 (+SQL) on SD
      • colour highlighting does NOT work
      • trail search works
      • this is NOT expected behaviour
    3. both maps (+both SQL) on SD
      • both enabled
        • colour highlighting works for content of BOTH MAPS
        • trail search only Topo Austria Trails
        • this is expected behaviour for the highlighting and unexpected behaviour for the trail search, but could be explained by a conflict of having two SQL .db files on one card
      • Austria enabled, Transalpine disabled
        • colour highlighting does NOT work
        • trail search only Topo Austria Trails
        • this is NOT expected behaviour for the highlighting
      • Austria disabled, Transalpine enabled
        • colour highlighting works
        • trail search only Topo Austria Trails
        • this is NOT expected behaviour for the highlighting, for trail search see above
    4. both maps (+ ONLY austria SQL) on SD
      • highlighting is EXACTLY the same as with both SQL files
      • trail search is EXACTLY the same as with both SQL files
    5. both maps (+ ONLY transalpine SQL) on SD
      • highlighting is EXACTLY the same as with both SQL files
      • trail search now only for Transalpine
    6. both maps (+ NO SQL FILE) on SD
      • highlighting is EXACTLY the same as with both SQL files
      • no Trails button in search available


    In summary, I found the following things:
    • highlighting has NOTHING to do with the SQL files, they are totally unrelated
    • SQL files are only used for the trail search function
    • the austria SQL file overrides the transalp SQL file
    • you can only use one SQL file on the montana in trail search, how it is determined which one is used I don't yet know, but I'm investigating
    • the topo austria v3 highlighting ONLY works when topo transalpine 2012 is on the same card and enabled as well


    For the SQL file problem, I will look into a possibility of combining the databases in one file and report back once I know more...
    But how do we solve the highlighting problem? Any ideas?

    Since I don't have my original TopoAustria SD Card here right now,

    could anyone confirm if the highlighting works on the original SD

    cause I slowly have a suspicion that this might also not work on the original map.. maybe a bug in the firmware or in the released map?

    For completeness sake, all of this was tested on a Montana 650 with FW 4.20.
    Quote Originally Posted by MaxDoe View Post
    okay, so this shows that two SQL files do not work on the same card, and this will be solved by Garmin. So this problem is done as far as I am concerned.

    Leaves us with a problem that has nothing to do with the SQL files in any way, the highlighting in Topo Austria, which strangely seems to be "activated" by enabling the transalpine topo at the same time.....

    Quote Originally Posted by Mapperoni View Post
    The problem with multiple db files (only one of them gets loaded) still exists with the latest firmware releases dated 29/30 august.
    I checked it myself with v4.40 on my 62s and on forum.garmin.de someone reports the same for the Montana.

    We'll have to wait for Garmin to tackle this problem.
    note:
    ActiveRouting functionalities supported by Montana, Monterra, Edge 810/1000, GPSMAP 62/64 and Oregon 6xx/x50 series
    more info about active routing and named trails:
    [Only registered and activated users can see links. ]
    end of the starting post

    see also
    [Only registered and activated users can see links. ]
    [Only registered and activated users can see links. ]
    [Only registered and activated users can see links. ]
    [Only registered and activated users can see links. ]

    [Only registered and activated users can see links. ]
    You have to navigate to get to the good.
    Nuvi1250/Nuvi 34xx/Nuvi 2200/Nuvi 66/Oregon 600/Galaxy S5 MM 6.0.1/TomTom GO/iGO Nextgen Avic,Basar,Isr.Gift/Navigon
    Please don't flood my pm box with questions you can post on forum!! You won't hear back from me.

  4. #3
    Master sergio2's Avatar
    Join Date
    Nov 2011
    Location
    Spain
    Age
    49
    Posts
    345
    Rep Power
    125

    Default

    Hi,

    I originally posted this problem on Montana discussions thread ; because I had no answer, I am posting here :

    Has anybody already experimented (on Montana) new active routing "search trails" with new european topo maps ?
    When trails buttom is selected in "where to go", trails are displayed very slowly, and when one is selected, Montana freezes.
    In addition to .db file, should it lack .unl or .gma file ?

  5. #4
    ☼ADMIN☼
    catymag's Avatar
    Join Date
    Nov 2007
    Location
    light side
    Posts
    23,573
    Rep Power
    5313

    Default

    In 62 I disabled DEM or it's a nightmare, too slow with these maps.
    [Only registered and activated users can see links. ]
    [Only registered and activated users can see links. ]

    [Only registered and activated users can see links. ]
    You have to navigate to get to the good.
    Nuvi1250/Nuvi 34xx/Nuvi 2200/Nuvi 66/Oregon 600/Galaxy S5 MM 6.0.1/TomTom GO/iGO Nextgen Avic,Basar,Isr.Gift/Navigon
    Please don't flood my pm box with questions you can post on forum!! You won't hear back from me.

  6. #5
    Navigation software expert

    Giomen's Avatar
    Join Date
    Apr 2009
    Location
    Suomi-Russia
    Age
    49
    Posts
    2,578
    Rep Power
    589

    Default

    I not find anywhere what FID, PID and other ID are contained in .UNL file...
    Love your wife? Buy yourself a GPS for answering to her favorite question: "Dear, where are you?".

  7. #6
    Senior Member
    Join Date
    Jun 2011
    Location
    at Home
    Posts
    104
    Rep Power
    7

    Default

    If I have two image files in my Oregon, where do I put the two corresponding SQL folders? I can't have the same named folders in Garmin? (Images like Gmapsupp and Gmapsup2 or Gmapprom)
    Last edited by HaraldGPS; 29th September 2012 at 23:15.

  8. #7
    ☼ADMIN☼
    catymag's Avatar
    Join Date
    Nov 2007
    Location
    light side
    Posts
    23,573
    Rep Power
    5313

    Default

    I quote here a post from Topo Germany thread:
    Quote Originally Posted by sergio2 View Post
    Hi,

    New Montana firmware allows several .db files in the same SQL folder to be read on GPS.
    I tried with Topo France v3, Topo Germany v3, and Topo trek Map Italia v3 : the whole three maps trails were displayed when "trails" in "where to go" was selected.
    [Only registered and activated users can see links. ]
    [Only registered and activated users can see links. ]

    [Only registered and activated users can see links. ]
    You have to navigate to get to the good.
    Nuvi1250/Nuvi 34xx/Nuvi 2200/Nuvi 66/Oregon 600/Galaxy S5 MM 6.0.1/TomTom GO/iGO Nextgen Avic,Basar,Isr.Gift/Navigon
    Please don't flood my pm box with questions you can post on forum!! You won't hear back from me.

  9. #8
    Navigation software expert

    Giomen's Avatar
    Join Date
    Apr 2009
    Location
    Suomi-Russia
    Age
    49
    Posts
    2,578
    Rep Power
    589

    Default

    Caty, Garmin developers in quiet mode as usually added this last point in change list at last week

    Spoiler: CLICK
    http://www8.garmin.com/support/download_details.jsp?id=5335
    Love your wife? Buy yourself a GPS for answering to her favorite question: "Dear, where are you?".

  10. #9
    Important User


    Join Date
    May 2010
    Location
    Netherlands
    Posts
    598
    Rep Power
    367

    Default

    The problem with multiple db files (only one of them gets loaded) still exists with the latest firmware releases dated 29/30 august.
    I checked it myself with v4.40 on my 62s and on forum.garmin.de someone reports the same for the Montana.
    The problem is solved for the 62s with the latest firmware v4.80.
    Nüvi 2595 / 60CSx / 62s / Oregon 600

  11. #10
    Global Moderator

    smokefree's Avatar
    Join Date
    Sep 2010
    Location
    @ home
    Age
    36
    Posts
    3,298
    Rep Power
    717

    Default

    Quote Originally Posted by Giomen View Post
    I not find anywhere what FID, PID and other ID are contained in .UNL file...
    Any news on how to unlock the SQL file?

 

 
Page 1 of 3 123 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
This website uses cookies
We use cookies to store session information to facilitate remembering your login information, to allow you to save website preferences, to personalise content and ads, to provide social media features and to analyse our traffic. We also share information about your use of our site with our social media, advertising and analytics partners.