Welcome guest, is this your first visit? Click the "Create Account" button now to join.
Page 2 of 2 FirstFirst 12
Results 11 to 15 of 15
  1. #11
    Junior Member
    Join Date
    Aug 2011
    Location
    Bulgaria
    Posts
    6
    Rep Power
    0

    Default

    Quote Originally Posted by Neil View Post
    @xxlfozy
    I can't understand why you're having problems other than now by re-installing an older version of the Garmin USB driver over [Only registered and activated users can see links. ] you've caused a compatibility problem. Using current usb driver both current BC v4.2.5 and the beta release of upcoming v4.3.0.2 work well in my Windows 8.1 with my SP 2610:
    ..........
    Maybe you need to completely uninstall everything and start again. It is possible to run the beta version of BaseCamp 4.3.0.2 side by side with an earlier version.
    Probably I miss something:

    garmin usb 1

    garmin usb 2

    Map Sourse unit ID

    Map Sourse version

    What you mean full remove. I use uninstall program from Control Panel\All Control Panel Items\Programs and Features

    Thanks

  2.    Advertissements


  3. #12
    Garmin/GPS Systems GMod.

    Neil's Avatar
    Join Date
    Aug 2011
    Location
    Oz.
    Posts
    7,407
    Rep Power
    1435

    Default

    It seems your problem is not with MS or BC or USB drivers, it's with the device itself or how Windows is treating it. StreetPilot 2610 does not connect in Mass Storage Mode in Windows, so i don't know why your BMW unit is being recognised as such and given a drive letter [E:] by Windows. It should not be visible as a removable device at all. It would normally be seen by MS & BC directly without it appearing in Windows Explorer/Computer or Device Manager/Disk Management.

    I suppose you have already tried cold rebooting your PC, then reconnecting the GPS after it's powered up, and finally opening MS or BC.

    This is how SP 2610 should appear, only shown in Devices & Printers without a letter:

    2610 prop

    GARMIN (H:) showing in Disk Management above is not the SP, it's a 4GB logical drive on my main HDD.

    I have had no direct dealings with the BMW II navigators, but i believe that you are correct when you say the hardware is the same as SP 2610. There are slight differences in the firmware only afaik.
    'Thanking Posts' are banned. To thank someone, and/or to see hidden links and content, use the [Only registered and activated users can see links. ] button below left of the helpful post then refresh your browser [F5 key]. 'Thanking Posts' are banned.
    Please don't spam. Posts serving no purpose other than to thank or to ask about hidden links are trashed or deleted, it's GPSPower's policy. Please don't spam.
    [Only registered and activated users can see links. ] should make their first post as a new Intro Thread in [Only registered and activated users can see links. ].

  4. #13
    Junior Member
    Join Date
    Aug 2011
    Location
    Bulgaria
    Posts
    6
    Rep Power
    0

    Default

    Drive E is my HCSD card.
    I've tried to make same scr.shots like yours.

    WIN 7
    garmin usb WIN 7

    WIN 8.1
    garmin WIN 8 1

    I will tray BaseCamp 4.3.0.2 BETA

  5. #14
    Garmin/GPS Systems GMod.

    Neil's Avatar
    Join Date
    Aug 2011
    Location
    Oz.
    Posts
    7,407
    Rep Power
    1435

    Default

    OK, i think i understand now. I misunderstood before because you had the card 'E' in the 'Safely Remove Hardware and Eject Media' pop-up showing in your first screenshot in Post #11. I assumed you'd done that intentionally. My mistake. However, I'm unsure why you have drawn a question mark in your latest screenshot for Win 7 Disk Management. If you are thinking that the unit should be displayed there in some way, that's not the case with these older nav units. The modern nuvi-type units do show there when connected in Mass Storage Mode, but 26x0 SP era units do not show nor do they have a drive letter allocated.

    So, in precis - In Win 7 on another PC you can see the unit in 'Devices and Printers' correctly and it's recognised by BaseCamp with no problems. But in Win 8.1 you get the yellow triangle error and it's not recognised by BC.

    I guess a picture is worth a thousand words and i realise that English is not your first language. In 8.1 Devices and Printers, and then C:/Windows, please follow this:

    BC 8 1 2610

    You should have both gmngen.sys and gmnusb.sys shown under 'Driver File Details'. If either or both are not shown then reload the current Garmin USB driver version 3.2.1.0. If both files are shown, then proceed to C:/Windows/System32/drivers. Locate the 2 files, and check that the required permissions are allowed for 'All Application Packages' for both of those files.
    'Thanking Posts' are banned. To thank someone, and/or to see hidden links and content, use the [Only registered and activated users can see links. ] button below left of the helpful post then refresh your browser [F5 key]. 'Thanking Posts' are banned.
    Please don't spam. Posts serving no purpose other than to thank or to ask about hidden links are trashed or deleted, it's GPSPower's policy. Please don't spam.
    [Only registered and activated users can see links. ] should make their first post as a new Intro Thread in [Only registered and activated users can see links. ].

  6. #15
    Junior Member
    Join Date
    Aug 2011
    Location
    Bulgaria
    Posts
    6
    Rep Power
    0

    Default

    Probably it was important to mention that I use USB3 on convertible tablet.

    I checked every thing on my both systems and I have full control like you pictures but without success.
    I decided to uninstall driver, to remove these two files from ...\drivers. I did this but the files were missed from C:/Windows/System32/drivers WTF. I found them in C:\Windows\System32\DriverStore\FileRepository... copied them and paste in C:/Windows/System32/drivers. No effect
    Every time after reinstall the USB driver massage (install new usb driver) was appearing on taskbar. This shouldn't be happend.
    When I checked for first time the files grmn**.sys have been there. Some *.exe was putted there.
    Several attempts and 4 hours.
    Clear all and again. Start from old version 2.3.0.0. The files is appear on C:/Windows/System32/drivers.
    Check every thing that you was recomended me, NO PROBLEM
    Connect SP II on USB2-mini and YES, YES, YES "Houston we have contact"
    On pic can see some changes in course of reinstall.

    garmin WIN 8 1c

    VICTORY
    Base Camp WIN 8 1c

    I would say a BIG THANK YOU. You show me that it's possible to connect SPII with WIN8.1 and motivate me to keep trying.
    If you land in Bulgaria, drop my a PM. You've got me a bottle beverage of my personal production .

 

 
Page 2 of 2 FirstFirst 12

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
This website uses cookies
We use cookies to store session information to facilitate remembering your login information, to allow you to save website preferences, to personalise content and ads, to provide social media features and to analyse our traffic. We also share information about your use of our site with our social media, advertising and analytics partners.