Welcome guest, is this your first visit? Click the "Create Account" button now to join.
Page 3 of 4 FirstFirst 1234 LastLast
Results 21 to 30 of 35
  1. #21
    Navigation software expert

    Cnfhbr's Avatar
    Join Date
    Jan 2010
    Location
    CIS
    Posts
    1,223
    Rep Power
    476

    Default

    Quote Originally Posted by Abedul View Post
    You can find a piece of the map here below
    Thanks for the test map.
    Could you give the coordinates of some problematic crossing points (or nodes) of the map, in addition?

    Note: When checking this map for errors the MicroGIS Editor has found 109 errors of the Routing graph there, see the [Only registered and activated users can see links. ]
    Incidentally, the "Verify Map" is available in the unregistered version of MGE too.
    Last edited by Cnfhbr; 26th March 2014 at 12:09. Reason: added note

  2.    Advertissements


  3. #22
    Member +
    Join Date
    Jun 2010
    Location
    Madrid , Spain
    Posts
    33
    Rep Power
    0

    Default

    Hello CNFHBR
    You can find on the Test_map2 some missing crossing points .
    [Only registered and activated users can see links. ]
    This is the resulting img, decompiled with MapEdit. Wrong crossing points are located on road Identities: 376718 (1), 21792 (2) and 598331.
    I use MicroGIS EDitor for Verify function but those kind of errors do not give any problems, I refer to White nodes and Roads not sliced at intersecctions, other ones I correct them.

    Kind regards

  4. #23
    Member +
    Join Date
    Jun 2010
    Location
    Madrid , Spain
    Posts
    33
    Rep Power
    0

    Default

    I forgot one think.If you like to check mp2shp working with my map it could be useful to heve _types file, you can find here
    [Only registered and activated users can see links. ]

  5. #24
    Navigation software expert

    Cnfhbr's Avatar
    Join Date
    Jan 2010
    Location
    CIS
    Posts
    1,223
    Rep Power
    476

    Default

    Quote Originally Posted by Abedul View Post
    Wrong crossing points are located on road Identities: 376718 (1), 21792 (2) and 598331.
    These roads are of the Type=0x13 in your source map.
    This Type=0x13 corresponds to the GRMN_TYPE "CUSTOMIZABLE_ROUTE_LINE_7" in your _types file.
    You should add this custom type of road into your _config file.
    For example:
    Code:
    Please Login or Register to see the links
    Note: This must be done for all custom routable polylines separated by commas without spaces.
    Last edited by Cnfhbr; 26th March 2014 at 20:06. Reason: highlighted in red

  6. #25
    Member +
    Join Date
    Jun 2010
    Location
    Madrid , Spain
    Posts
    33
    Rep Power
    0

    Default

    This is done, CRL7 is asigned to type 0x13 as one of the 7 customizable routing lines, and it works well in most of the cases, but there are some missing crossing points
    You can see asignation on the _tipes file I sent on previous post. I think this is not the reson of the problem

  7. #26
    Navigation software expert

    Cnfhbr's Avatar
    Join Date
    Jan 2010
    Location
    CIS
    Posts
    1,223
    Rep Power
    476

    Default

    Could you lay out your _config file in addition?

  8. #27
    Member +
    Join Date
    Jun 2010
    Location
    Madrid , Spain
    Posts
    33
    Rep Power
    0

    Default

    This file has not changed at all from the origineal content, see below
    [Only registered and activated users can see links. ]

  9. #28
    Navigation software expert

    Cnfhbr's Avatar
    Join Date
    Jan 2010
    Location
    CIS
    Posts
    1,223
    Rep Power
    476

    Default

    Quote Originally Posted by Abedul View Post
    This file has not changed at all from the original content ...
    See your _config file:
    Code:
    Please Login or Register to see the links
    Where is the CUSTOMIZABLE_ROUTE_LINE_7 and other your custom routable polylines there?
    Therefore, the utility mp2shp believes that this polyline is unroutable.
    Carefully read my post #24 above ...

  10. #29
    Navigation software expert

    Cnfhbr's Avatar
    Join Date
    Jan 2010
    Location
    CIS
    Posts
    1,223
    Rep Power
    476

    Default

    By default, the utility mp2shp forwards to the routing graph only standard Garmin Roads, see script _mp2shp1.pl:
    Code:
    Please Login or Register to see the links
    If you use Custom Roads, custom types of such roads must be registered in the _config to participate in routing!

    Not necessarily use long anonymous types of Custom Roads (like CUSTOMIZABLE_ROUTE_LINE_1-7), you can edit it to your liking, for example:

    A) Edit in the MPC settings, see the [Only registered and activated users can see links. ]
    Note: This is not case sensitive and can't contain spaces.

    B) Edit in the _types file:
    Code:
    Please Login or Register to see the links
    C) And edit in the _config file:
    Code:
    Please Login or Register to see the links
    Notes:
    1. Do not use excessive Custom Roads, not all GPS-units support properly these roads during routing.
    2. The _config file contains many important settings besides the above, place it in the installation directory of mp2shp, next to the executable file.

  11. #30
    Member +
    Join Date
    Jun 2010
    Location
    Madrid , Spain
    Posts
    33
    Rep Power
    0

    Default

    Hi CNFHBR.
    Many thanks for your interest
    I have changed file _config trying to follow your indications, see below new _config
    [Only registered and activated users can see links. ]
    I do not know is there is something wrong but I continue with same problema.
    Because of Reading again Readme fie , I do NOT all routing lines splitted at nodes because it is a huge work, but in mos cases it Works in some others no.
    I have made a new test with Custom Routing lines splitted and no splitted, in both the cases it fails. See below the test, mp and resulting img
    [Only registered and activated users can see links. ]
    New lines are on the righ hand side, if you like I can send you mu typ file to see it better.

    Kind regards

 

 
Page 3 of 4 FirstFirst 1234 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
This website uses cookies
We use cookies to store session information to facilitate remembering your login information, to allow you to save website preferences, to personalise content and ads, to provide social media features and to analyse our traffic. We also share information about your use of our site with our social media, advertising and analytics partners.